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1.​ Which key selects all cells in a worksheet? 

a.​ Ctrl + C 

b.​ Ctrl + A 

c.​ Ctrl + V 

d.​ Ctrl + Z 

Answer: b. Ctrl + A 

Explanation: Ctrl + A selects every cell in the active worksheet, which is commonly used 

before formatting, copying, or deleting entire data in Excel. 

 

2.​ How can you select an entire row in Excel? 

a.​ Click the row number on the left 

b.​ Click the column letter at the top 

c.​ Press Ctrl + C 

d.​ Press Ctrl + Z 

Answer: a. Click the row number on the left 

Explanation: Clicking the row number selects all cells in that row, making it easy to format, 

delete, or copy the entire row. 

 

3. How can you select an entire column in Excel? 

a.​ Click the row number on the left 

b.​ Click the column letter at the top 

c.​ Press Ctrl + A 

d.​ Press Ctrl + V 

Answer: b. Click the column letter at the top 

Explanation: Clicking the column letter selects all cells in that column for formatting, 

copying, or deleting. 
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4. After pressing Ctrl + A, how can you select a specific row or column? 

a.​ Press Ctrl + C 

b.​ Press Ctrl + Z 

c.​ Click the top edge of the row/column header 

d.​ Click any cell 

Answer: c. Click the top edge of the row/column header 

Explanation: After selecting all cells with Ctrl + A, clicking the header edge highlights the 

specific row or column for further actions. 

 

3.​ Which shortcut selects a complete row? 

a.​ Shift + Spacebar 

b.​ Ctrl + Spacebar 

c.​ Alt + Spacebar 

d.​ Shift + Enter 

Answer: a. Shift + Spacebar 

Explanation: This shortcut highlights the entire row of the active cell, allowing quick 

row-based operations such as delete or insert. 

 

4.​ Which shortcut selects a complete column? 

a.​ Shift + Spacebar 

b.​ Ctrl + Spacebar 

c.​ Ctrl + Shift 

d.​ Alt + Enter 

Answer: b. Ctrl + Spacebar 

Explanation: Ctrl + Spacebar selects the whole column in which the cursor is placed. 
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5.​ How to select non-adjacent rows or columns? 

a.​ Ctrl key 

b.​ Shift key 

c.​ Double click 

d.​ Select all 

Answer: a. Ctrl key 

Explanation: Holding the Ctrl key allows selecting multiple rows or columns that are not 

next to each other. 

 

6.​ Which tab is used to insert a row? 

a.​ Data 

b.​ View 

c.​ Insert 

d.​ Home 

Answer: d. Home 

Explanation: Row insertion options are available under the Home tab in Excel. 

 

7.​ How can you insert a new row in Excel? 

a.​ Home > Insert > Insert Sheet Rows 

b.​ Home > Delete 

c.​ Ctrl + Z 

d.​ Ctrl + V 

Answer: a. Home > Insert > Insert Sheet Rows 

Explanation: This adds a new row above the selected cell. 
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8.​ Which action inserts a row quickly? 

a.​ Right click 

b.​ Double click 

c.​ Drag 

d.​ Delete key 

Answer: a. Right click 

Explanation: Right-clicking a row header gives a shortcut menu with the Insert option. 

 

9.​ How to insert multiple rows? 

a.​ Ctrl + A 

b.​ Shift + Space 

c.​ Alt + (+) 

d.​ Ctrl + (+) 

Answer: d. Ctrl + (+) 

Explanation: Selecting rows and pressing Ctrl + plus inserts the same number of new rows. 

 

10.​Which option inserts a single cell? 

a.​ Shift cells 

b.​ Merge 

c.​ Wrap 

d.​ Format Painter 

Answer: a. Shift cells 

Explanation: Shift cells move existing cells to create space for a new cell. 
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11.​Which shortcut deletes a row? 

a.​ Ctrl + + 

b.​ Shift + – 

c.​ Alt + Del 

d.​ Ctrl + – 

Answer: d. Ctrl + – 

Explanation: Ctrl + minus deletes the selected row, column, or cell. 

 

12.​Which option removes a cell and shifts data? 

a.​ Merge 

b.​ Wrap 

c.​ Shift cells 

d.​ Format Painter 

Answer: c. Shift cells 

Explanation: Excel shifts remaining cells to maintain the worksheet layout. 

 

13.​How can you delete a row or column using the Ribbon? 

a.​ Home > Delete 

b.​ Right-click > Insert 

c.​ Ctrl + Z 

d.​ Format Painter 

Answer: a. Home > Delete 

Explanation: Deletes the selected row or column via the Home tab. 
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14.​How can you delete a row or column using the right-click menu? 

a.​ Right-click > Delete 

b.​ Right-click > Insert 

c.​ Home > Wrap Text 

d.​ Ctrl + A 

Answer: a. Right-click > Delete 

Explanation: Deletes the selected row or column from the context menu. 

 

15.​How do you delete a single cell using the Home tab? 

a.​ Home > Insert > Insert Sheet Rows 

b.​ Right-click > Insert 

c.​ Home > Delete > Delete Cells > Shift cells up/left 

d.​ Ctrl + A 

Answer: c. Home > Delete > Delete Cells > Shift cells up/left 

Explanation: Deletes the selected cell and shifts the surrounding cells up or left. 

 

16.​How do you delete a single cell using the right-click menu? 

a.​ Right-click > Delete > Shift cells up/left 

b.​ Right-click > Insert 

c.​ Home > Wrap Text 

d.​ Ctrl + Z 

Answer: a. Right-click > Delete > Shift cells up/left 

Explanation: Right-clicking allows you to delete a cell and move the remaining cells up or 

left. 
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17.​What happens when you delete a cell and choose “Shift cells up”? 

a.​ Cells to the right move left 

b.​ Cells below move up to fill the space 

c.​ The entire row is deleted 

d.​ The entire column is deleted 

Answer: b. Cells below move up to fill the space 

Explanation: Shift cells up moves the content of cells below into the deleted cell’s position. 

 

18.​Which option is used to move data to a new location in Excel?  

a.​ Copy and Paste 

b.​ Cut and Insert 

c.​ Paste Special 

d.​ Format Painter  

Answer: b. Cut and Insert 

Explanation: Cut and Insert moves data from one place to another by removing it from the 

original location and shifting cells automatically. 

 

19.​What are Merge Cells in Excel? 

a.​ Combine cells into one cell 

b.​ Split one cell 

c.​ Delete cells 

d.​ Copy cells 

Answer: a. Combine cells into one cell 

Explanation: 'Merge Cells' is used to join two or more selected cells into a single cell, 

usually for headings or titles in Excel. 
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20.​Where is Merge & Centre found? 

a.​ Data 

b.​ Home 

c.​ View 

d.​ Insert 

Answer: b. Home 

Explanation: Merge & Center is located in the Alignment group of the Home tab. 

 

21.​What does Merge Across do? 

a.​ Row merge 

b.​ Full merge 

c.​ Delete 

d.​ Wrap 

Answer: a. Row merge 

Explanation: Merge Across merges cells in each row separately. 

 

22.​What is the purpose of Wrap Text? 

a.​ Increase width 

b.​ Merge 

c.​ Multi-line text 

d.​ Delete 

Answer: c.  Multi-line text 

Explanation: Wrap Text displays cell content on multiple lines without changing column 

width. 
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23.​Where is Wrap Text located? 

a.​ Home 

b.​ Data 

c.​ View 

d.​ Insert 

Answer: a. Home 

Explanation: Wrap Text is available under the Alignment group in the Home tab. 

 

24.​Which shortcut is used to “Find options” ? 

a.​ Ctrl + F 

b.​ Ctrl + H 

c.​ Ctrl + R 

d.​ Ctrl + G 

Answer: a. Ctrl + F 

Explanation: Ctrl + F is used to search text or numbers in a worksheet. 

 

25.​Which shortcut opens Replace? 

a.​ Ctrl + F 

b.​ Ctrl + R 

c.​ Ctrl + L 

d.​ Ctrl + H 

Answer: d. Ctrl + H 

Explanation: Ctrl + H replaces existing text or values across the worksheet. 
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26.​What does Replace All do? 

a.​ Replace everything 

b.​ Replace one 

c.​ Find next 

d.​ Close Option 

Answer: a. Replace everything 

Explanation: Replace All updates every matching item in the worksheet. 

 

27.​Which tool copies formatting? 

a.​ Format Painter 

b.​ Fill Handle 

c.​ Wrap Text 

d.​ Filter 

Answer: a. Format Painter 

Explanation: The Format Painter copies font style, color, and size from one cell to another. 

 

28.​Which tab has the Group option? 

a.​ Home 

b.​ Data 

c.​ View 

d.​ Insert 

Answer: b. Data 

Explanation: The Group and Ungroup options are found in the Data tab. 
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29.​Grouping is used to __________. 

a.​ Summarize data 

b.​ Delete data 

c.​ Merge cells 

d.​ Format text 

Answer: a. Summarize data 

Explanation: Grouping hides detailed data and shows summary rows or columns. 

 

30.​Which key opens Save As? 

a.​ F12 

b.​ F11 

c.​ F10 

d.​ F9 

Answer: a. F12 

Explanation: F12 opens the Save As dialog box. 

 

31.​What does the asterisk (*) wildcard represent? 

a.​ Only one character 

b.​ Only numbers 

c.​ Any number of characters 

d.​ Only symbols 

Answer: c. Any number of characters 

Explanation: The asterisk can match multiple characters or even no characters at all in a 

search pattern. 
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32.​Which wildcard represents a single character? 

a.​ ? 

b.​ * 

c.​ . 

d.​ _ 

Answer: a. ? 

Explanation: The question mark (?) wildcard matches exactly one character in the search 

text. 

 

33.​Which search pattern finds words like “project”, “process”, and “profile”? 

a.​ pro? 

b.​ *pro 

c.​ pro* 

d.​ ?pro 

Answer: c. pro* 

Explanation: The asterisk allows any number of characters after “pro”, so all matching 

words are found. 

 

34.​Which pattern finds “cat”, “cut”, and “cot” but not “cart”? 

a.​ c?t 

b.​ c*t 

c.​ ?at 

d.​ c??t 

Answer: a. c?t 

Explanation: The question mark replaces only one character, so three-letter words match, 

but longer words do not. 
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35.​In Excel, wildcard characters are mainly used in: 

a.​ Sorting 

b.​ Formatting 

c.​ Find and Replace 

d.​ Chart creation 

Answer: c. Find and Replace 

Explanation: Wildcard characters help search text patterns efficiently in the Find and 

Replace feature. 

 

36.​What is the primary purpose of the sorting feature in Excel? 

            a.   To find and replace data 

            b.   To change the appearance of data 

            c.   To arrange data in a specific order 

            d.   To add new rows and columns 

Answer: c. To arrange data in a specific order 

Explanation: Sorting helps organize data in order, making it easier to read and analyze. 

 

37.​How can you sort data in ascending order using the Sort feature? 

a.​  Home -> Format -> Sort A to Z 

b.​  Data -> Sort -> Sort A to Z 

c.​  Review -> Sort -> Sort A to Z 

d.​  File -> Sort -> Sort A to Z 

Answer: b. Data -> Sort -> Sort A to Z 

Explanation: To sort data in ascending order, you go to the "Data" tab on the Ribbon and 

click on "Sort A to Z". This will arrange the selected column’s data from the smallest to the 

largest value. 
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38.​Which of the following options allows you to perform a multi-level sort? 

a.​ Home → Sort 

b.​ Data → Filter 

c.​ Data → Sort → Custom Sort → Add Level 

d.​ Review → Sort → Custom Sort 

Answer: c. Data → Sort → Custom Sort → Add Level 

Explanation: Multi-level sorting is done from the Data tab → Sort (Custom Sort), then use 

Add Level to sort by multiple columns. 

 

39.​What does the filter feature in Excel do? 

a.​ Highlights specific cells 

b.​ Hides rows that don’t match the criteria 

c.​ Changes cell color 

d.​ Deletes rows permanently 

Answer: b. Hides rows that don’t match the criteria 

Explanation: Filter shows only the data that meets the condition and hides the rest. 

 

40.​Which option sorts numbers from high to low? 

a.​ Largest to Smallest 

b.​ A to Z 

c.​ smallest to highest 

d.​ Z to A 

Answer: a. Largest to Smallest 

Explanation: This sorting option arranges values in descending order. 
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41.​Which order is A to Z? 

a.​ Descending 

b.​ Ascending 

c.​ Random 

d.​ Filtered 

Answer: b. Ascending 

Explanation: A to Z sorting arranges data from smallest to largest. 

 

42.​Which tab has the Sort option? 

a.​ Data 

b.​ Home 

c.​ Insert 

d.​ View 

Answer: a. Data 

Explanation: The Sort option is located under the Data tab. 

 

43.​Which option sorts dates correctly? 

a.​ Largest to Smallest 

b.​ A to Z 

c.​ Z to A 

d.​ Oldest to Newest 

Answer: d. Oldest to Newest 

Explanation: Date values are sorted based on time order. 
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44.​Which option adds a second sort column? 

a.​ Add Level 

b.​ Filter 

c.​ Group 

d.​ Wrap 

Answer: a. Add Level 

Explanation: Add Level allows sorting using multiple columns. 

 

45.​Which tool shows selected records? 

a.​ Sort 

b.​ Merge 

c.​ Filter 

d.​ Wrap 

Answer: c. Filter 

Explanation: A Filter displays only required data and hides the rest. 

 

46.​Which tab has the Filter tool? 

a.​ Data 

b.​ Home 

c.​ Insert 

d.​ Review 

Answer: a. Data 

Explanation: The Filter option is available in the Data tab. 
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47.​What happens when you clear a filter from a column? 

a.​ All rows become visible again 

b.​ The column is deleted 

c.​ Only filtered rows are kept 

d.​ The data is sorted automatically 

Answer: a. All rows become visible again 

Explanation: Clearing a filter removes the filtering criteria, making all rows visible once 

again. This does not alter or delete any data. 

 

48.​How can you sort a list of dates in descending order? 

a.​ Home -> Format -> Sort Newest to Oldest 

b.​ Data -> Sort -> Sort Z to A 

c.​ Data -> Sort -> Sort Newest to Oldest 

d.​ Insert -> Sort -> Sort Newest to Oldest 

Answer: c. Data -> Sort -> Sort Newest to Oldest 

Explanation: Go to the Data tab, click Sort, and choose Newest to Oldest to arrange dates 

from most recent to oldest.  

 

49.​Which of the following options is NOT a type of filter available in Excel? 

a.​ Text Filters 

b.​  Number Filters 

c.​ Color Filters 

d.​ Row Filters 

Answer: d. Row Filters 

Explanation: Excel provides Text Filters, Number Filters, and Color Filters. There is no 

option called Row Filters; filtering is typically applied to columns.  
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50.​In Excel, how can you remove all filters applied to a worksheet? 

a.​ Data -> Clear Filters 

b.​ Home -> Remove Filters 

c.​ Data -> Filter -> Clear 

d.​ File -> Options -> Remove Filters 

Answer: c. Data -> Filter -> Clear 

Explanation: To remove all filters, you can go to the "Data" tab, click on the "Filter" button, 

and select "Clear". This will remove all the filters applied and display all rows. 

 

51.​Which of the following sorting options is available in Excel? 

a.​ Sort by color 

b.​ Sort by font size 

c.​ Sort by column width 

d.​ Sort by data validation rules 

Answer: a. Sort by color 

Explanation: Excel supports sorting data based on cell or font color to help highlight and 

organize information visually. 

 

52.​How do you apply a filter to a range of data in Excel? 

a.​ Home → Insert → Filter 

b.​ View → Filter 

c.​ Data → FilterFile → Filter 

Answer: c. Data → Filter 

Explanation: The Filter option under the Data tab adds dropdowns to column headers for 

filtering values. 
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53.​ What is the row of column titles called when applying a filter? 

a.​ Footer Row 

b.​ Print Titles 

c.​ Header Row 

d.​ Worksheet Row 

Answer:  c. Header Row 

Explanation: The Header Row has column titles that Excel uses for sorting and filtering. 

It adds drop-down lists to each column for easy filtering. 

54.​What happens when you click the Filter command? 

a.​ Drop-down arrows appear in each column header. 

b.​ A filter dialog box opens. 

c.​ A checklist of column titles appears. 

d.​ Nothing happens. 

Answer : a. Drop-down arrows appear in each column header. 

Explanation: The Filter adds drop-down arrows to each column so you can sort or filter 
the data. 

 

55.​When data is arranged in ascending or descending order for only 1 column is called 

__________. 

a.​ Multiple Column Sorting 

b.​ One Bar Sorting 

c.​ Single Column Sorting 

d.​ None of the above 

Answer : c. Single Column Sorting 

Explanation: When data is arranged in ascending or descending order based on values in 
only one column, it is referred to as Single Column Sorting. 
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56.​Sorting is done in ___________ ways. 

a.​ One 

b.​ Two 

c.​ Three 

d.​ Four 

Answer :  b. Two 

Explanation: Sorting is done in two ways: Ascending (A to Z / Smallest to Largest) and 

Descending (Z to A / Largest to Smallest). 

57.​What is the main purpose of using an Outline in Excel? 

a.​ To format cells 

b.​ To group and summarize data 

c.​ To sort data 

d.​ To create charts 

Answer: b. To group and summarize data 

Explanation: Outline groups related rows or columns so data can be summarized and 

viewed easily. 

 

58.​ How many outline levels can Excel support? 

a.​ 5 

b.​ 6 

c.​ 8 

d.​ 10 

Answer: c. 8 

Explanation: Excel allows creating outlines with a maximum of eight grouping levels. 
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59.​Which Excel feature allows collapsing and expanding grouped data? 

a.​ Filter 

b.​ Outline 

c.​ Conditional Formatting 

d.​ Data Validation 

Answer: b. Outline 

Explanation: The Outline feature provides plus (+) and minus (–) buttons to expand or 

collapse data. 

 

60.​Which key moves the cursor to the next cell? 

a.​ Tab 

b.​ Shift + Tab 

c.​ Ctrl + N 

d.​ Ctrl + S 

Answer: a. Tab 

Explanation: Pressing Tab moves the active cell to the next cell on the right. 

 

61.​Which shortcut moves the cursor to the previous cell? 

a.​ Shift + Tab 

b.​ Tab 

c.​ Ctrl + W 

d.​ Ctrl + O 

Answer: a. Shift + Tab 

Explanation: Shift + Tab moves the selection to the previous cell on the left. 
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62.​Which shortcut creates a new workbook? 

a.​ Ctrl + O 

b.​ Ctrl + S 

c.​ Ctrl + N 

d.​ Ctrl + W 

Answer: c. Ctrl + N 

Explanation: Ctrl + N opens a new blank workbook in Excel. 

 

63.​Which shortcut opens an existing workbook? 

a.​ Ctrl + N 

b.​ Ctrl + O 

c.​ Ctrl + S 

d.​ Ctrl + F4 

Answer: b. Ctrl + O 

Explanation: Ctrl + O opens the Open dialog box to access an existing file. 

 

64.​Which shortcut closes the current workbook? 

a.​ Ctrl + W 

b.​ Ctrl + F4 

c.​ Ctrl + S 

d.​ Ctrl + N 

Answer: a. Ctrl + W 

Explanation: Ctrl + W closes the active workbook without exiting Excel. 
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65.​Which shortcut closes Microsoft Excel completely? 

a.​ Ctrl + W 

b.​ Ctrl + O 

c.​ Ctrl + S 

d.​ Ctrl + F4 

Answer: d. Ctrl + F4 

Explanation: Ctrl + F4 closes the Excel application entirely. 
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